Removing Box on Main Page

RigilKent
RigilKent

Hi there! I apologize in advance if this has been answered - I looked through the CSS Discussions and just didn't see it. I'm trying to help a buddy set up a new campaign for our F2F group (https://blackroses.obsidianportal.com/) and noted something that, until now, I hadn't really observed but now am seeing everywhere, including on my site. Specifically, there's a box on the front page that we're trying to make go away. I've already got the transparency going on and that works if you scroll down, but if you don't, this box is ... distracting. Anyone know some CSS to make it go away? I tried Inspecting the page, but I can't seem to get the one for just that box itself...

Thanks for any assistance!

Current Campaign - Traveller: The Verge - Campaign of the Month July 2020.

 

Comments

  • thaen
    thaen
    Posts: 975

    Did you figure this out?  I don't think I'm seeing the issue when I checked the site just now.

     

     

    Obsidian Portal Developer

  • thaen
    thaen
    Posts: 975

    image

    Obsidian Portal Developer

  • RigilKent
    RigilKent
    Posts: 13

    Hmm. It appears to be a Chrome-specific issue ... Not seeing this in Firefox...

    Current Campaign - Traveller: The Verge - Campaign of the Month July 2020.

     

  • thaen
    thaen
    Posts: 975

    The screenshot I posted is from Chrome, and I'm not seeing the issue in the screenshot (let me know if I'm missing it).

    But you are still seeing it?

    Obsidian Portal Developer

  • Abersade
    Abersade
    Posts: 316

    Small update regarding this question: I saw RigilKent's question on Discord today and worked with him to fashion a workaround which "should" prevent this from being visible. Due to the error being on the browser side of the fence reproducing the issue was... spotty, so let me know if this doesn't work for you.

    https://abersade-testbed.obsidianportal.com/wikis/errors

  • thaen
    thaen
    Posts: 975

    If y'all are happy with the solution, that definitely works for me.  But feel free to bring it back up if there's still an issue.

    Obsidian Portal Developer

  • Abersade
    Abersade
    Posts: 316 edited January 27

    Just to be clear, a workaround isn't in itself a solution. I'd rather identify the issue that is causing Chrome to fail to load the background image completely and work towards a real solution. That said; I'm no web developer and thus lack most of the required skillset to troubleshoot this issue from that perspective, the impact of the problem appears to be fairly limited, and we have a workaround available. As such it likely doesn't warrant the effort unless more folks start reporting it as a problem.

    Thinking about this a bit more, I do have to wonder why I've never seen this occur on any of my campaign sites. I do my CSS development almost exclusively in Chrome so you would think that if this occurs even 0.5% of the time when a page is loaded that I would have seen it on one of my own pages by now. That in turn leads me to believe that there is a specific combination of factors that RigilKent's campaign sites have in common that are contributing to the problem. Without performing a CSS deepdive there I would just be grasping at straws but my initial instinct would point at the image size or some CSS cascade issue. Then again, one would think that if it was either of those things the issue would be consistently reproducible. 

    /shrug

    Post edited by Abersade on
  • thaen
    thaen
    Posts: 975

    Agree on all fronts.  Especially "one would think that if it was either of those things the issue would be consistently reproducible."  So yeah, at this point, we'll wait to see if anyone else is having the issue.

    Obsidian Portal Developer

Sign In or Register to comment.

November 2022
Curse of the Crimson Throne

Read the feature post on the blog
Return to Obsidian Portal

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions