Any tips for Tooltips?

jasonjcrick

I'm building an in-game calendar and I would like to have mouseover tooltips which cause events to pop out from their respective dates. It works fine in the preview but it doesn't work live in Chrome or Edge. I haven't tried Firefox, I'd appreciate if somebody could. Does anybody know what's happening here? The tooltips are in a table, but I've tried them out of it and had the same result, and again, it works fine in the preview.

Much appreciated <3

The page looks like this; https://pages.obsidianportal.com/wikis/the-schedule

The code looks like this;


h3. *Dentercyc, 868*

|Up|Down|Spin|Shin|Eye|Frin|Sky|Hel|Skel|Syn|Mot|
|[tooltip][tooltip-title]1[end-tooltip-title][tooltip-content] Belladonna, Leylanus and Many arrive in Side Table [end-tooltip-content][end-tooltip] |2 |3 |4 | 5 |6 |7 |8 |9 |[tooltip][tooltip-title]_10_[end-tooltip-title][tooltip-content] Expedition #1 Departs [end-tooltip-content][end-tooltip] |11 |
|12 |13 |14 |15 |16 |17 |18 |19 |20 |21 |22 |
|23 |24 |25 |26 |27 |28 |29 |30 |31 |32 |33 |
|34 |35 |36 |37 |38 |39 |40 |41 |42 |43 |44 |

 

Comments

  • thaen
    thaen
    Posts: 219

    This looks like it's a bug in the parser related to textile tables. 

    The quick fix for your situation is to remove all of the space after the last "|" so that the cursor is sitting right up next to it (no new lines) before you hit Save.

    You'll know you've got it right when you see the (supposed to be "right") sidebar with the "See All Pages" button back up on the right instead of down at the bottom on the left.

    For some reason the parser is trying to add in some extra HTML tags when it's creating the table HTML if there is anything after the table, and that's messing up where the hidden "tooltip" div tags are sitting, so they can't be found when you're hovering over the link.

  • thaen
    thaen
    Posts: 219

    I played with this a little more and it looks like an even better fix is to put a space before and after the "_10_" in the second tooltip, so it looks like "[tooltip-title] _10_ [end-tooltip-title]".

    If you do that, then you can have as much space or other text come after the table and it won't mess up the HTML.

  • jasonjcrick
    Posts: 3

    Thank you so much for replying!



    It's gently relieving to know that I'm not just going mad.

    I've tried both of your fixes and still can't see tooltips when it's live in Chrome. The cursor changes on mouseover as though the numbers were a link, but no text appears.



    Thank you for your efforts, it's amazing to have this kind of help.

  • thaen
    thaen
    Posts: 219

    Happy to help!

    Cool, the HTML is looking good now.  The issue now is that the JavaScript Inserts (like Tooltips) are an Ascendant feature and the GM of this Campaign is not Ascendant, so if the GM of the Campaign upgrades to Ascendant, the hovers will immediately start working (after a refresh of the page).

    Just curious, how were you able to get the syntax for the Tooltip without the Campaign being Ascendant already?  Usually in an Ascendant Campaign the wiki page author uses the "Tooltip" button on the side of the Textile window, and that brings up the "Tooltip Generator" popup, which then creates the Tooltip syntax and inserts it into the Textile window.  (I'm trying to figure out if we have a bug or something?)

  • jasonjcrick
    Posts: 3

    Ah. That'll be it then.

    I got the syntax by googling it, there was no button. 

    Guess I'll upgrade! Thank you!

  • thaen
    thaen
    Posts: 219

    Nice googling skills!

    Happy to help!

  • twiggyleaf
    twiggyleaf
    Posts: 1,686

    Ascendancy is always divine!

    smiley

    "I met a traveller from an antique land....."

    CotM May 2016: Mysteria: set in Wolfgang Baur’s MIDGARD.

    Previous CotM Aug 2012: Shimring: High Level Multiplanar Campaign

    Inner Council Member

Sign In or Register to comment.

August's Campaign of the Month, In Search of Hidden Dragons!

Read the feature post on the blog!
Or return to Obsidian Portal!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions