Issue: Spacing between text and table

DungeonMasterLoki
DungeonMasterLoki

Anyone else have this issue or know of a fix? I've got a wiki page that is giving me massive display issues that I cannot figure out. 

For some reason, there is a gulf of white space (about 50 carriage returns) between the body text and the table that is to display beneath it. Table is in simple html and there are no stray characters or spaces in the code between it and the body text. 

The page in question should you care to look. 

Any input appreciated, trying to rebuild a bunch of stuff I deleted from OP years ago. Thanks in advance! 

Planejammer Panopticon: Central Hub for the Planejammer Campaign Series

Current Active Games:

Planejammer: Catch My Drift! (Starfinder RPG)

Planejammer: The Spelljoined (Pathfinder RPG) Campaign of the Year 2011

 

Comments

  • thaen
    thaen
    Posts: 219

    Looking into this to see what's going on.  Thanks for reporting it!

  • DungeonMasterLoki
    DungeonMasterLoki
    Posts: 284

    I remember seeing it crop up before, right after the reforge when I was last active. Just encountered it while rebuilding. 

    Planejammer Panopticon: Central Hub for the Planejammer Campaign Series

    Current Active Games:

    Planejammer: Catch My Drift! (Starfinder RPG)

    Planejammer: The Spelljoined (Pathfinder RPG) Campaign of the Year 2011

     

  • thaen
    thaen
    Posts: 219

    I think this will get you fixed up for now...

    On "Earth 29", remove the extra carriage return that is between the "td" and "Mirror-cosmology of Earth 19".  That shouldn't be causing an issue, but it is, so there's a bug there in the renderer that I need to look into closer.

    On "Earth 73", add a "td tr" to the end of that line to close the cell and row.

    Let me know if those two changes don't clear up the issues for you.

  • DungeonMasterLoki
    DungeonMasterLoki
    Posts: 284

    Changes effected, no difference in display output. Thanks for the fast response! 

     

    Planejammer Panopticon: Central Hub for the Planejammer Campaign Series

    Current Active Games:

    Planejammer: Catch My Drift! (Starfinder RPG)

    Planejammer: The Spelljoined (Pathfinder RPG) Campaign of the Year 2011

     

  • Kallak
    Kallak
    Posts: 1,015

    Have you tried putting a return between the text and the opening table tag? I didn't want to save an edit to your page without permission, but from previewing, it appears to correct the issue.

    All the best,
    - Kallak

    Inner Council Member
    CotM Selection Committee
    Writer/Editor - Words In The Dark
    Obsidian Portal Community and Content Manager
    GameMaster - Crucible of the Blacksoul (CotM for Jan. 2013)

  • thaen
    thaen
    Posts: 219

    Ah, yep, sorry, adding a return between the table and the paragraph above it was the other change I made.

  • gastoff
    gastoff
    Posts: 76

    Is it a padding/margin issue with the elements themselves? Maybe the default campaign CSS has a set px border causing the undesidered gap between the elements?

    image

  • thaen
    thaen
    Posts: 219

    The html renderer that processes the posts was getting confused with the missing row and cell closing tags, and with the way the renderer wanted the carriage returns to be placed.  So the renderer was putting in a bunch of extra "br" and "p" elements between the text and the table.  So this wasn't related to css.

    I did take a look at the renderer to see if I could make it more tolerant of the carriage return placements, but it's not an easy fix.  Since there is a workaround of just changing the carriage returns that shouldn't be too bad for now.  Longer-term we need to upgrade the renderer.

  • DungeonMasterLoki
    DungeonMasterLoki
    Posts: 284

    @kallak Adding that carriage return did it! Thanks SO much for that one. 

    @thaen so remember to go in and add closing tags to everything. That is easy to deal with. Relatively minor in the grand scheme of things and immediate efforts best sent elsewhere right now. Thanks! 

    Oh, and maybe I'm just blind, but I can't find the spot to edit my forum sig. Nothing in the profile. Where should I look to add that, if you please? 

    Planejammer Panopticon: Central Hub for the Planejammer Campaign Series

    Current Active Games:

    Planejammer: Catch My Drift! (Starfinder RPG)

    Planejammer: The Spelljoined (Pathfinder RPG) Campaign of the Year 2011

     

  • thaen
    thaen
    Posts: 219

    To update your forum signature...

    Click on the "person" (Profile) button in the top right hand corner.

    Then click on the "Edit Profile" link in roughly the middle of the upper part of the page.

    Then scroll down on the right hand side, and click "Signature Settings".

    Then update and Save.

    Hope that helps!

  • aaron_cammarata
    aaron_cammarata
    Posts: 2

    Hi everyone!

    I'm having (what I think is) a similar problem, at least in terms of root cause.

    I tried searching the forums to see if there was already a fix, this was the best looking thread. (If you want me to start a new thread to track my issue, lmk. Thanks!)

    I have indented unordered lists, and the html renderer seems to be inserting extra <br> tags.

    While my case isn't identical (text & table), the same words are showing up (html renderer, extra <br> tags, complicated fix...).

    The source is:

    <h4>[[Sparklesea]]</h4>


    <ul>

        <li>[[City Hall]]

        <ul>

            <li>[[Office of Planetary Protection]]</li>

        </ul>

        </li>

        <li>[[The Library]]</li>

    </ul> 

    But when this renders, there is an extra <br> tag after  "City Hall".

    It looks like the "ul" renderer is auto-inserting a br tag, maybe?

    If there's a workaround for this as well, would be very grateful for pointers. Thanks!

  • Kallak
    Kallak
    Posts: 1,015

    Is this with the CKEditor or the Textile editor?

    All the best,
    - Kallak

    Inner Council Member
    CotM Selection Committee
    Writer/Editor - Words In The Dark
    Obsidian Portal Community and Content Manager
    GameMaster - Crucible of the Blacksoul (CotM for Jan. 2013)

  • thaen
    thaen
    Posts: 219

    @aaron_cammarata, welcome!  This thread works just fine.

    This is a similar issue, definitely due to the renderer and also not an easy fix in the renderer. But, I think there is a work around.  Try the below version and see if it gets rid of the <br>.  Specifically, I pulled the nested "<ul>" up onto the parent "<li>" line, and then also pulled up the first "<li>" nested child on to that same line.  If you need more "nested <li> children", they can go on their own lines.  It's only the <ul> and the first child that need to move up to prevent the <br> bug.

     

    <h4>[[Sparklesea]]</h4>

    <ul>



        <li>[[City Hall]]<ul><li>[[Office of Planetary Protection]]</li>



        </ul>



        </li>



        <li>[[The Library]]</li>



    </ul> 

Sign In or Register to comment.

August's Campaign of the Month, In Search of Hidden Dragons!

Read the feature post on the blog!
Or return to Obsidian Portal!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions