YouTube Broken Again

24

Comments

  • abu_is_evil
    abu_is_evil
    Posts: 168

    Why am I not surprised...

    Just trying to help out.

  • Johnprime
    Johnprime
    Posts: 252

    I think I'm going to have to come up with an image placeholder, then link to my Youtube teaser video and just redirect my OP site visitors there.

    Johnprime

    Deadwood Deacon Banner

    Where the west is really wild!

    The Valley of Life Banner

    The Valley of Life

  • cgregory
    cgregory
    Posts: 772

    Speaking as a developer myself, these devs really need to do some quality assurance testing before implementing changes.

    Considering that the most common feature to break is the oembed function this should be one the things that needs to be tested in the test environment before implementation in production. If they don't have a test environment, then they should be testing this after any implementation and have a plan to rollback any implementation that causes issues.

    They are among us!

    image

    Current Campaign: XCom: Defiance - Campaign of the Month November 2016

                                           My Campaign CSS

                              Unlocking The Portal: A Guide to OP CSS                                    

     

     

  • Johnprime
    Johnprime
    Posts: 252

    I'm right there with you cgregory!

    Johnprime

    Deadwood Deacon Banner

    Where the west is really wild!

    The Valley of Life Banner

    The Valley of Life

  • jasonvey
    jasonvey
    Posts: 52

    Agreed, 100%. It's infuriating for one of the basic features of a service many of us pay to use to constantly go down for a month or more at a time. 

  • cgregory
    cgregory
    Posts: 772

    I got a reply from Alan, from Customer Support, regarding this issue, basically saying that the dev is saying that youtube's api changed and that is why it isn't working. I've checked and yes YouTube did have a scheduled API change on Feb 10, 2017.  However, the first reported instance of the issue occurred on Feb 6th.

    I disagree with their dev's assessment for another main reason. If it was just due to an API change from youtube then only youtube should have stopped working. As it is, all types of embedding have stopped working including pdf files hosted on mediacloud (where OP's media library sits), and sound files hosted on soundcloud. So he must have changed something as well.

    I've spoken to Alan stressing the fact that it is not just Youtube that is affected, but all media embedding types are affected and Alan is making sure the dev is aware of that fact rather than it just being a youtube api issue. 

     

    They are among us!

    image

    Current Campaign: XCom: Defiance - Campaign of the Month November 2016

                                           My Campaign CSS

                              Unlocking The Portal: A Guide to OP CSS                                    

     

     

  • Robling
    Robling
    Posts: 18

    ...plus you can't edit existing comments in forums anymore. Seriously, wtf.

  • SkidAce
    SkidAce
    Posts: 829

    That problem comes and goes also @Robling.

    In the thread where you want to edit a previous comment, make a new post with say a single letter "x".

    You can edit that post, and from the edit screen, delete it.

    Bam, that previous comment you wanted to edit?  It can be edited now.

     

     

  • joeschmoe998
    joeschmoe998
    Posts: 73

    Any updates on SoundCloud or YouTube?

  • jasonvey
    jasonvey
    Posts: 52

    Over a month since we've been able to embed files. 

    AGAIN.

    There's one word for this continual interruption in service: Unacceptable. 

    I'm especially angry as I've got a bunch of extra people looking at my page this month, only to be greeted with massive empty, ugly white spaces. Whatever OP did last month, it's time to roll it the heck back. We don't need changes or "upgrades" if they're going to screw up core functionality. 

  • Eingya
    Eingya
    Posts: 5

    That didn`t last much...

  • abu_is_evil
    abu_is_evil
    Posts: 168

    They have not been consistent on this issue since Kaleidoscope took over- one of the main reasons we left.

    Just trying to help out.

  • barrelv
    barrelv
    Posts: 22

    If there was a better alternative that didn't require from-scratch site creation, I'd consider leaving at this point. Easily some of the worst for-pay service I use. Even the headache at getting the 20-30 players across our 4-5 campaigns would be worth the switch effort. But, for now, the dynamic style templates are keeping us in place.

  • Johnprime
    Johnprime
    Posts: 252

    I've built quite a few from-scratch websites that I've used for gaming, and the other problem with building them, besides time, is that if you're using a code base, say like PHP, when the version of PHP changes, quite often you have to go back to those same websites and re-code. I've got a nice, IMO, Gamma World website that I built years ago that my players at that time used quite a bit. But it was built using PHP from at least 3 versions ago and there are major bugs that are there now because of changes to PHP that I really don't have the motivation to go fix.

    One of these days I plan on fixing the site, but right now, it's easier for me to use OP. Specially since the majority of my players from the current group tend to be less enthusiastic about visiting the site, even the OP site.

    Johnprime

    Deadwood Deacon Banner

    Where the west is really wild!

    The Valley of Life Banner

    The Valley of Life

  • Robling
    Robling
    Posts: 18 edited March 2017

    My concern with all this isn't so much about whether or not the vid-links work, really, though that is somewhat annoying. I have always supported the site, encouraged my players to visit and support the site, and even other gamers I don't regularly game with or simply have an interest in my campaigns from a peripheral view of things.

    No, ultimately what bothers me about it, is the silence. OP Support has always been too silent on these and other issues. When they choose to do an update, they don't inform anyone, even on Facebook, with a simple warning about maintenance or other issues. In a society increasingly tied to social media, that should be the first concern in any situation, is regular information to the consumers about changes, updates or other issues, and thus heading off a huge number of concerns and problems with your subscriber base.

    But time and again all we get is silence, or a professional-sounding comment followed by continued silence. That, I fear is their failing. They don't ultimately seem to care about we the subscribers, whether or not it works, there's no flow of information. Unfortunate, really.

    Post edited by Robling on
  • SkidAce
    SkidAce
    Posts: 829

    Yeah, its been my feeling for a while that they are in maintenance mode, and not development mode.

  • Bortas
    Bortas
    Posts: 645 edited March 2017

    Honestly, "maintenance" is a bit generous, more like "occasional fire extinguishing".

    -bort

    Post edited by Bortas on
  • cgregory
    cgregory
    Posts: 772

    I've found generally the only way to get a response from OPSupport is by logging a support ticket.

    https://www.obsidianportal.com/support

    It does sometimes take sometime for a response to be forthcoming but I have gotten a response to every ticket I've placed.

    I think they are in some sort of development mode, because there is no reason for all embedded features to stop working without some change in the code base. Their dev saying that a youtube api change caused this issue just doesn't hold up scrutiny, since music files and PDFs are affected as well. The only reason for all types of embedding to fail is that the dev changed something.

     

    They are among us!

    image

    Current Campaign: XCom: Defiance - Campaign of the Month November 2016

                                           My Campaign CSS

                              Unlocking The Portal: A Guide to OP CSS                                    

     

     

  • SkidAce
    SkidAce
    Posts: 829

    I'm not sure cgregory, but I will trust your expertise.

    This issue has come and gone for YEARS, and I would always get the impression that when it started working again they were just as amazed as us.

    Sometimes they even denied it was an issue.  And then turned around and "fixed" it.  I think its a configuration, or setup issue, where a disconnect shows up somewhere and nobody can find it until they reboot a computer and lo, it works again.

     

    But those are layman's terms, and I bow to your superior coding skills.

  • abu_is_evil
    abu_is_evil
    Posts: 168

    I had 38 tickets open when I was banned, and out of those only 6 have been resolved since.

    Just trying to help out.

  • jasonvey
    jasonvey
    Posts: 52

    I always fail to understand what seems to be the developer's drive to fix what isn't broken in all sectors of technology. These "updates," if that's what's causing it, aren't adding any value; they're just making a mess of things. So stop. Just. Stop. Put it back the way it was and let it go. 

  • Robling
    Robling
    Posts: 18

    I'd link a meme from "Frozen".... but...

  • jasonvey
    jasonvey
    Posts: 52

    STILL nothing? Wow, I think the devs owe us an explanation at this point. Not that they'll actually give one. It's become clear that they don't value providing a solid service to their paying customers. 

  • cgregory
    cgregory
    Posts: 772

    Looks like OPSupport has brought this up multiple times with the dev(s) but he isn't getting any response from them.

    They are among us!

    image

    Current Campaign: XCom: Defiance - Campaign of the Month November 2016

                                           My Campaign CSS

                              Unlocking The Portal: A Guide to OP CSS                                    

     

     

  • Johnprime
    Johnprime
    Posts: 252

    I'd say I agree with you Jason, but, we don't know what the work load of the devs is. If this is the only site they are working on,then yes, they are falling down on the job and something needs to be done, but they might have multiple sites they are working on and the development schedule for OP isn't high on the list of priorities.

    Johnprime

    Deadwood Deacon Banner

    Where the west is really wild!

    The Valley of Life Banner

    The Valley of Life

  • cgregory
    cgregory
    Posts: 772

    All I can suggest is everyone needs to send a ticket. Get it pushed to the top of the OP fix list.

    They are among us!

    image

    Current Campaign: XCom: Defiance - Campaign of the Month November 2016

                                           My Campaign CSS

                              Unlocking The Portal: A Guide to OP CSS                                    

     

     

  • Johnprime
    Johnprime
    Posts: 252

    Exactly cgregory!

    Johnprime

    Deadwood Deacon Banner

    Where the west is really wild!

    The Valley of Life Banner

    The Valley of Life

  • OPSupport
    OPSupport
    Posts: 93

    You are correct - I will keep requesting according to your tickets. Sorry if I post the same general response to this issue in tickets, but it is genuine - I am waiting for a fix.

    The availability of the devs is not under my control, but I will keep trying to obtain a fix for this issue and others.

    Alan

  • abu_is_evil
    abu_is_evil
    Posts: 168

    So how do we encourage Kaleidoscope to put more emphasis and developer time here on Obsidian Portal?  Not being sarcastic- really want to help put focus on fixing the site!

    Just trying to help out.

Sign In or Register to comment.

Campaign of the Month
September 2021

D&D 3.0: Tales from Mystara


Read the feature post on the blog!
Or return to Obsidian Portal!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions