Odd Content Box issue

Mr_Motivator
Mr_Motivator
edited August 2015 in Campaign Portal Building
Hey guys/gals,

Im a complete noob when it comes to css/textiles and im learning as i go along. Iv received a butt load of help from various posts and the community here is pretty amazing. But im in need cause im going crazy.

So i have made a middle piece, top piece and bottom piece of some parchment paper and im attempting to code it so it generates on everything content box wise. However for some odd reason the top/bottom of my boxes have this lower res version of the texture im using.
I thought at first its my art reapting on itself and just being a bit naff but that isnt the case where there is a load of it repeated, https://tmits.obsidianportal.com/characters/kobold. As you can see on that page, the paper repeats quite nicely its just the top and bottom that for some reason loads at a lower res as if another image is generating over the top.

http://i.imgur.com/KOEHpvH.jpg

My question is have i accidently duplicated my parchment generation or done something wrong here:

.adventure-log-show .post-main,
.campaign-public-layout #character-details,
.post-player-secret.post-section.player-secret,
.wiki-page, .wiki-edit,
.post-main,
.character-show .main-content section,
.item-show .main-content section {
background-color : transparent;
background-image: url('http://i1006.photobucket.com/albums/af184/tmits/Middle%20test_zpsz3fnvhw2.png');
background-position:center;
background-size:100%;
position:relative;
}

.post-player-secret.post-section.player-secret:before,
.post-player-secret.post-section.player-secret:after,
.adventure-log-show .post-main:before,
.adventure-log-show .post-main:after,
.wiki-page:after, .wiki-page:before,
.character-show .main-content section:after,
.character-show .main-content section:before,
.item-show .main-content section:after,
.item-show .main-content section:before {
background-color : transparent;
background-size:100%;
position:absolute;
background-repeat:no-repeat;
left:-2px;
width:100%;
height:34px;
content:"";
background-position: center center;
z-index:10;
}

.post-player-secret.post-section.player-secret:before,
.adventure-log-show .post-main:before,
.wiki-page:before,
.character-show .main-content section:before,
.item-show .main-content section:before {
background-image: url('http://i1006.photobucket.com/albums/af184/tmits/Top%20Test_zpsh4pr7lsw.png');
top:-10px;
left:0px;
}

.post-player-secret.post-section.player-secret:after,
.adventure-log-show .post-main:after,
.wiki-page:after,
.character-show .main-content section:after,
.item-show .main-content section:after {
background-image: url('http://i1006.photobucket.com/albums/af184/tmits/Bottom%20Test_zpsfvmbgt7e.png');
bottom:-10px;
left:0px;
}

Thanks in advance if you can help, if not thats cool too the community has been more than helpful already.

Comments

  • Mr_Motivator
    Mr_Motivator
    Posts: 19
    Upon further investigating i think i realise the problem, my Top/Bottom texture is picking the wrong time to be placed on my middle texture piece. So my new question is:

    How can i code context boxes to have my parchment textures but have it so it wrapps correctly. I have the whole texture piece i just cut it up for the sake of css code.
  • Mr_Motivator
    Mr_Motivator
    Posts: 19
    Neverrrrmiiiind, i figured it out. I basicly had a tiny offset in pixels causing a odd overlap. Also didnt help that my "top" and "bottom" images had a harsh edge and needed a fade to blend. Issue resolved :)
  • GamingMegaverse
    GamingMegaverse
    Posts: 2,966
    Glad you got it figured...

    Just trying to help out.

Sign In or Register to comment.

August 2022
In Over Their Heads

Read the feature post on the blog
Return to Obsidian Portal

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Discussions